XCode 3.2.6 and Code Sense trouble

  • XCode 3.2.6 on 10.8.3, Carbon, 10.5 SDK.

    I have a Carbon app that is using 10.5 as the Base SDK and as the
    Deployment Target.

    I have the 10.4u SDK installed as well as we were using this at one point.

    Another developer added some functionality from HIToolbox/Events.h.

    He compiles file. I get an undefined error.

    If I do an "Open Quickly" I see Events.h and it says from: "MacOSX10.4u ->
    Carbon -> HIToolbox -> Events.h"

    If the other developer does the same steps, his says: "MacOSX10.5 -> Carbon
    -> HIToolbox -> Events.h"

    He says he has the 10.4u SDK installed as well.

    I tried re-building the Code Sense Index but I am not sure what it did, if
    it has any real effect or what I should do next.
  • On May 29, 2013, at 5:00 pm, Jason T. Slack-Moehrle <slackmoehrle...> wrote:

    > He says he has the 10.4u SDK installed as well.
    >
    > I tried re-building the Code Sense Index but I am not sure what it did, if it has any real effect or what I should do next.

    Xcode 3.2 has the Overview popup in the toolbar. Option click on it and there will be a 'Active SDK' section. Make sure you have the 10.5 SDK chosen. Note that this appears to be separate from the SDK chosen for the project.
previous month may 2013 next month
MTWTFSS
    1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 31    
Go to today