Xcode and IB connection

  • Hi,

    I've got a problem with a project I'm working on for a long time now.

    Suddenly the connection between Xcode and IB is lost. Normally when opening a nib/xib file from Xcode, IB gets started and in the status bar of IB a green "light" appears left to the project name telling me that Xcode and IB are in sync. This "light" is now grey all the time and the hoover-text tells me, that there is no Xcode Project associated with the NIB-Document. This is definitely not true! I've removed the NIB from the Xcode Project and added it again with no success.

    This problems exist for every NIB/XIB in the Project and there are several.

    Any help would be appreciated.

    Joachim
  • On Jan 17, 2010, at 6:40 AM, Joachim Deelen wrote:

    > Hi,
    >
    > I've got a problem with a project I'm working on for a long time now.
    >
    > Suddenly the connection between Xcode and IB is lost. Normally when opening a nib/xib file from Xcode, IB gets started and in the status bar of IB a green "light" appears left to the project name telling me that Xcode and IB are in sync. This "light" is now grey all the time and the hoover-text tells me, that there is no Xcode Project associated with the NIB-Document. This is definitely not true! I've removed the NIB from the Xcode Project and added it again with no success.
    >
    > This problems exist for every NIB/XIB in the Project and there are several.

    Does it show proper target relationship under the "target" tab of the "info" o the XIB?

    Keary Suska
    Esoteritech, Inc.
    "Demystifying technology for your home or business"
  • Hi Keary,

    thanks for the reply.

    Yes, Target-Dependancy is correct.

    In the meanwhile I found this: http://lists.apple.com/archives/xcode-users/2009/Oct/msg00368.html.

    Chris Espinosa states, that two different Versions of Xcode may be installed, since opening the project by double clicking on the xcodeproj-file works around the problem. I definitely have only one copy of Xcode installed.

    It's Version 3.2.1
    Component versions
    Xcode IDE: 1613.0
    Xcode Core: 1614.0
    ToolSupport: 1591.0

    These Version Numbers stay the same, no matter if I start Xcode directly from /Developer/Applications, from the Reference in the Dock or by double clicking on a project-file.

    For now I can live with the workaround. I'm working on the project on different computers. On my MacBook Pro, there is no Problem at all. But is has a newer OS X version than 10.6.2...

    -
    Joachim

    Am 17.01.2010 um 16:12 schrieb Keary Suska:

    > On Jan 17, 2010, at 6:40 AM, Joachim Deelen wrote:
    >
    >> Hi,
    >>
    >> I've got a problem with a project I'm working on for a long time now.
    >>
    >> Suddenly the connection between Xcode and IB is lost. Normally when opening a nib/xib file from Xcode, IB gets started and in the status bar of IB a green "light" appears left to the project name telling me that Xcode and IB are in sync. This "light" is now grey all the time and the hoover-text tells me, that there is no Xcode Project associated with the NIB-Document. This is definitely not true! I've removed the NIB from the Xcode Project and added it again with no success.
    >>
    >> This problems exist for every NIB/XIB in the Project and there are several.
    >
    > Does it show proper target relationship under the "target" tab of the "info" o the XIB?
    >
    > Keary Suska
    > Esoteritech, Inc.
    > "Demystifying technology for your home or business"
    >
    >
  • On Jan 17, 2010, at 8:27 AM, Joachim Deelen wrote:

    > Hi Keary,
    >
    > thanks for the reply.
    >
    > Yes, Target-Dependancy is correct.
    >
    > In the meanwhile I found this: http://lists.apple.com/archives/xcode-users/2009/Oct/msg00368.html.
    >
    > Chris Espinosa states, that two different Versions of Xcode may be installed, since opening the project by double clicking on the xcodeproj-file works around the problem. I definitely have only one copy of Xcode installed.

    Hey Joachim -

    I'm glad you found a workaround, but that workaround doesn't necessary show that you only have one set of tools. When you get Xcode and IB both running, but not communicating, try command+clicking on the dock icons for the running Xcode and IB and make sure that the finder windows that pop up both reference the same folder. You might have "Developer (Previous Install)/Applciations" and "Developer/Applications".

    Jon Hess

    >
    > It's Version 3.2.1
    > Component versions
    > Xcode IDE: 1613.0
    > Xcode Core: 1614.0
    > ToolSupport: 1591.0
    >
    > These Version Numbers stay the same, no matter if I start Xcode directly from /Developer/Applications, from the Reference in the Dock or by double clicking on a project-file.
    >
    > For now I can live with the workaround. I'm working on the project on different computers. On my MacBook Pro, there is no Problem at all. But is has a newer OS X version than 10.6.2...
    >
    > -
    > Joachim
    >
    >
    >
    >
    > Am 17.01.2010 um 16:12 schrieb Keary Suska:
    >
    >> On Jan 17, 2010, at 6:40 AM, Joachim Deelen wrote:
    >>
    >>> Hi,
    >>>
    >>> I've got a problem with a project I'm working on for a long time now.
    >>>
    >>> Suddenly the connection between Xcode and IB is lost. Normally when opening a nib/xib file from Xcode, IB gets started and in the status bar of IB a green "light" appears left to the project name telling me that Xcode and IB are in sync. This "light" is now grey all the time and the hoover-text tells me, that there is no Xcode Project associated with the NIB-Document. This is definitely not true! I've removed the NIB from the Xcode Project and added it again with no success.
    >>>
    >>> This problems exist for every NIB/XIB in the Project and there are several.
    >>
    >> Does it show proper target relationship under the "target" tab of the "info" o the XIB?
    >>
    >> Keary Suska
    >> Esoteritech, Inc.
    >> "Demystifying technology for your home or business"
    >>
    >>
    >
    > _______________________________________________
    > Do not post admin requests to the list. They will be ignored.
    > Xcode-users mailing list      (<Xcode-users...>)
    > Help/Unsubscribe/Update your Subscription:
    > http://lists.apple.com/mailman/options/xcode-users/<jhess...>
    >
    > This email sent to <jhess...>
previous month january 2010 next month
MTWTFSS
        1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 31
Go to today