Executable path is nil! with gdp in xcode

  • I'm using xcode 2.2 with a c++ program. Xcode converted an older
    project file to its new format and I'm using that.

    The program complies and runs fine -- 2.2 puts exe's in development
    and deployment directories now.

    The problem is the debugger now won't work. When I try to debug I get the error
    "Executable path is nil!". Any idea what is going on?

    Thanks for any help.

    Steve
  • Inspect the active executable and check if the path is correct.

    -chrisF

    On Dec 14, 2005, at 3:16 PM, Steve Smith wrote:

    > I'm using xcode 2.2 with a c++ program. Xcode converted an older
    > project file to its new format and I'm using that.
    >
    > The program complies and runs fine -- 2.2 puts exe's in development
    > and deployment directories now.
    >
    > The problem is the debugger now won't work. When I try to debug I
    > get the error
    > "Executable path is nil!". Any idea what is going on?
    >
    > Thanks for any help.
    >
    > Steve
    > _______________________________________________
    > Do not post admin requests to the list. They will be ignored.
    > Xcode-users mailing list      (<Xcode-users...>)
    > Help/Unsubscribe/Update your Subscription:
    > http://lists.apple.com/mailman/options/xcode-users/<friesen...>
    >
    > This email sent to <friesen...>
  • That's the strange thing, the path is fine (it executes), just the debugger won't work.

    Is there a separate place that stores what path is passed to the debugger?

    -----Original Message-----
    From: Chris Friesen [mailto:<friesen...>]
    Sent: Wed 12/14/05 6:52 PM
    To: Smith, Steven J (PNNL/JGCRI)
    Cc: <xcode-users...>
    Subject: Re: Executable path is nil! with gdp in xcode

    Inspect the active executable and check if the path is correct.

    -chrisF

    On Dec 14, 2005, at 3:16 PM, Steve Smith wrote:

    > I'm using xcode 2.2 with a c++ program. Xcode converted an older
    > project file to its new format and I'm using that.
    >
    > The program complies and runs fine -- 2.2 puts exe's in development
    > and deployment directories now.
    >
    > The problem is the debugger now won't work. When I try to debug I
    > get the error
    > "Executable path is nil!". Any idea what is going on?
    >
    > Thanks for any help.
    >
    > Steve
    > _______________________________________________
    > Do not post admin requests to the list. They will be ignored.
    > Xcode-users mailing list      (<Xcode-users...>)
    > Help/Unsubscribe/Update your Subscription:
    > http://lists.apple.com/mailman/options/xcode-users/<friesen...>
    >
    > This email sent to <friesen...>
previous month december 2005 next month
MTWTFSS
      1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31  
Go to today