_objc_setProperty ObjC2.0 compile error ?

  • Hi

    I have a slight problem compiling a project in XCode 3 under Leopard.
    I have converted some of my classes to ObjC2.0 and have used the
    @property and @synthetize compiler "macros". Now I am unable to
    compile, compiler says:

      "_objc_setProperty", referenced from:

    Followed by a list of all the attributes in question.

    I have looked on Google and in the Doc but not a single hit, what am I
    missing ?

    Thank you!

    Charles
  • On Nov 13, 2007, at 1:35 PM, Charles Hamel wrote:

    > I have a slight problem compiling a project in XCode 3 under
    > Leopard. I have converted some of my classes to ObjC2.0 and have
    > used the @property and @synthetize compiler "macros". Now I am
    > unable to compile, compiler says:
    >
    > "_objc_setProperty", referenced from:
    >
    > Followed by a list of all the attributes in question.
    >
    > I have looked on Google and in the Doc but not a single hit, what am
    > I missing ?

    What SDK are you using, and if you're using the 10.5 SDK, then what
    deployment target are you using? The new stuff in the runtime requires
    Leopard for running and linking.

    Nick Zitzmann
    <http://www.chronosnet.com/>
  • Thank you, I have fixed my problem my simply re-creating a project
    with XCode 3 (the project was previously created by XCode 2.5) and it
    works

    Charles

    On 13-Nov-07, at 3:53 PM, Nick Zitzmann wrote:

    >
    > On Nov 13, 2007, at 1:35 PM, Charles Hamel wrote:
    >
    >> I have a slight problem compiling a project in XCode 3 under
    >> Leopard. I have converted some of my classes to ObjC2.0 and have
    >> used the @property and @synthetize compiler "macros". Now I am
    >> unable to compile, compiler says:
    >>
    >> "_objc_setProperty", referenced from:
    >>
    >> Followed by a list of all the attributes in question.
    >>
    >> I have looked on Google and in the Doc but not a single hit, what
    >> am I missing ?
    >
    >
    > What SDK are you using, and if you're using the 10.5 SDK, then what
    > deployment target are you using? The new stuff in the runtime
    > requires Leopard for running and linking.
    >
    > Nick Zitzmann
    > <http://www.chronosnet.com/>
    >
    >
    >
    >
previous month november 2007 next month
MTWTFSS
      1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30    
Go to today