My Xcode Project Won't Compile 32-Bit

  • I was messing around with using the 64-bit implementation of Cocoa and
    switched the "Architecture" build setting for the active configuration
    to $NATIVE_ARCH_ACTUAL which in my case is x86_64. I've been building
    a 64-bit version of my app for around a month and now I can't seem to
    go back to building a 32-bit i386 version. I have explicitly stated
    i386 in the build setting, cleaned the target, and then rebuilt my
    app. When I launch it, it continues to register as an Intel (64-Bit)
    app in activity monitor.

    Any suggestions on how to get back to 32-bit?

    Many thanks,
    -Aaron
  • On Oct 28, 2007, at 6:50 PM, Aaron Tait wrote:

    > I was messing around with using the 64-bit implementation of Cocoa
    > and switched the "Architecture" build setting for the active
    > configuration to $NATIVE_ARCH_ACTUAL which in my case is x86_64.
    > I've been building a 64-bit version of my app for around a month and
    > now I can't seem to go back to building a 32-bit i386 version. I
    > have explicitly stated i386 in the build setting, cleaned the
    > target, and then rebuilt my app. When I launch it, it continues to
    > register as an Intel (64-Bit) app in activity monitor.
    >
    > Any suggestions on how to get back to 32-bit?

    This is more of a question for xcode-users, but... Are you sure you
    edited and built the correct configuration?

    Nick Zitzmann
    <http://www.chronosnet.com/>
  • Since I am working with the Active Configuration build settings I am
    pretty sure this is correct. Thanks for pointing me to xcode-users.
    I'll post over there.

    -Aaron

    On 29-Oct-07, at 12:59 AM, Nick Zitzmann wrote:

    > This is more of a question for xcode-users, but... Are you sure you
    > edited and built the correct configuration?
previous month october 2007 next month
MTWTFSS
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31        
Go to today