GCC 3.3?

  • Hey all,

    I've installed Leopard, and now none of my projects compile with the
    error:

    "gcc 3.3: installation problem, cannot exec 'cc1obj': No such file or
    directory:
    (X)  Command /usr/bin/gcc-3.3 failed with exit code 1"

    I installed the DevTools off the DVD like normal, and I do have a file
    called "gcc-3.3" in /usr/bin/.

    I then tried reinstalling from just the GCC 3.3 package on the DVD,
    but that also doesn't work.

    Any idea why I can't compile?

    Thanks,

    Dave
  • When I got that error I used the perl script to delete the developer
    tools installation completely and reinstall them. That fixed it. I
    guess it happened because I ran the installer twice to fix the missing
    10.3.9 SDK.

    Annard

    On 27 Oct 2007, at 22:23, Dave DeLong wrote:
    > I've installed Leopard, and now none of my projects compile with the
    > error:
    >
    > "gcc 3.3: installation problem, cannot exec 'cc1obj': No such file
    > or directory:
    > (X)  Command /usr/bin/gcc-3.3 failed with exit code 1"
    >
    > I installed the DevTools off the DVD like normal, and I do have a
    > file called "gcc-3.3" in /usr/bin/.
    >
    > I then tried reinstalling from just the GCC 3.3 package on the DVD,
    > but that also doesn't work.
    >
    > Any idea why I can't compile?
  • And where might I find this perl script?

    Thanks,

    Dave

    On 27 Oct, 2007, at 3:50 PM, <ab_lists...> wrote:

    > When I got that error I used the perl script to delete the developer
    > tools installation completely and reinstall them. That fixed it. I
    > guess it happened because I ran the installer twice to fix the
    > missing 10.3.9 SDK.
    >
    > Annard
    >
    > On 27 Oct 2007, at 22:23, Dave DeLong wrote:
    >> I've installed Leopard, and now none of my projects compile with
    >> the error:
    >>
    >> "gcc 3.3: installation problem, cannot exec 'cc1obj': No such file
    >> or directory:
    >> (X)  Command /usr/bin/gcc-3.3 failed with exit code 1"
    >>
    >> I installed the DevTools off the DVD like normal, and I do have a
    >> file called "gcc-3.3" in /usr/bin/.
    >>
    >> I then tried reinstalling from just the GCC 3.3 package on the DVD,
    >> but that also doesn't work.
    >>
    >> Any idea why I can't compile?
    >
    >
  • Oh wait, I just found it.

    Thanks, I'll try this.

    Dave

    On 27 Oct, 2007, at 3:53 PM, Dave DeLong wrote:

    > And where might I find this perl script?
    >
    > Thanks,
    >
    > Dave
    >
    > On 27 Oct, 2007, at 3:50 PM, <ab_lists...> wrote:
    >
    >> When I got that error I used the perl script to delete the
    >> developer tools installation completely and reinstall them. That
    >> fixed it. I guess it happened because I ran the installer twice to
    >> fix the missing 10.3.9 SDK.
    >>
    >> Annard
    >>
    >> On 27 Oct 2007, at 22:23, Dave DeLong wrote:
    >>> I've installed Leopard, and now none of my projects compile with
    >>> the error:
    >>>
    >>> "gcc 3.3: installation problem, cannot exec 'cc1obj': No such file
    >>> or directory:
    >>> (X)  Command /usr/bin/gcc-3.3 failed with exit code 1"
    >>>
    >>> I installed the DevTools off the DVD like normal, and I do have a
    >>> file called "gcc-3.3" in /usr/bin/.
    >>>
    >>> I then tried reinstalling from just the GCC 3.3 package on the
    >>> DVD, but that also doesn't work.
    >>>
    >>> Any idea why I can't compile?
    >>
    >>

    >
  • Thanks, that worked great!

    Dave

    On 27 Oct, 2007, at 3:50 PM, <ab_lists...> wrote:

    > When I got that error I used the perl script to delete the developer
    > tools installation completely and reinstall them. That fixed it. I
    > guess it happened because I ran the installer twice to fix the
    > missing 10.3.9 SDK.
    >
    > Annard
    >
    > On 27 Oct 2007, at 22:23, Dave DeLong wrote:
    >> I've installed Leopard, and now none of my projects compile with
    >> the error:
    >>
    >> "gcc 3.3: installation problem, cannot exec 'cc1obj': No such file
    >> or directory:
    >> (X)  Command /usr/bin/gcc-3.3 failed with exit code 1"
    >>
    >> I installed the DevTools off the DVD like normal, and I do have a
    >> file called "gcc-3.3" in /usr/bin/.
    >>
    >> I then tried reinstalling from just the GCC 3.3 package on the DVD,
    >> but that also doesn't work.
    >>
    >> Any idea why I can't compile?
    >
    >
previous month october 2007 next month
MTWTFSS
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31        
Go to today