Weak-linking curl

  • Hi, we are using curl in our Application.

    Till now we required 10.4 and targeted that... the 10.4 curl static
    library was linked just fine.
    But now we want to cross-develop and support 10.3.9 as well... we
    know about weak-link and am confident about the apple frameworks, but
    what about curl....

    Hope you can help,
    Dominik
  • On Oct 5, 2006, at 2:11 PM, Dominik Pich wrote:

    > Till now we required 10.4 and targeted that... the 10.4 curl static
    > library was linked just fine.
    > But now we want to cross-develop and support 10.3.9 as well... we
    > know about weak-link and am confident about the apple frameworks,
    > but what about curl....

    I'm not sure what this has to do with Cocoa, but have you tried
    compiling CURL against the 10.3.9 SDK?

    Nick Zitzmann
    <http://www.chronosnet.com/>
  • FWIW I did link libcurl in our application as a Universal Binary
    private framework supporting 10.3.9 on the PPC side and 10.4.x on the
    Intel side. It's rather hacked together but it does work. If you are
    really desperate I can just e-mail you the whole thing (comes with
    instructions).

    On Oct 5, 2006, at 17:11 , Dominik Pich wrote:

    > Hi, we are using curl in our Application.
    >
    > Till now we required 10.4 and targeted that... the 10.4 curl static
    > library was linked just fine.
    > But now we want to cross-develop and support 10.3.9 as well... we
    > know about weak-link and am confident about the apple frameworks,
    > but what about curl....
    >
    > Hope you can help,
    > Dominik
    > _______________________________________________
    > Do not post admin requests to the list. They will be ignored.
    > Cocoa-dev mailing list      (<Cocoa-dev...>)
    > Help/Unsubscribe/Update your Subscription:
    > http://lists.apple.com/mailman/options/cocoa-dev/<oscarmv...>
    >
    > This email sent to <oscarmv...>
  • Hi im not sure what this has to do with cocoa either.... it's
    crossdevelopment so I guess I hit the wrong list. Sorry for that
    Am Oct 5, 2006 um 11:15 PM schrieb Nick Zitzmann:

    >
    > On Oct 5, 2006, at 2:11 PM, Dominik Pich wrote:
    >
    >> Till now we required 10.4 and targeted that... the 10.4 curl
    >> static library was linked just fine.
    >> But now we want to cross-develop and support 10.3.9 as well... we
    >> know about weak-link and am confident about the apple frameworks,
    >> but what about curl....
    >
    > I'm not sure what this has to do with Cocoa, but have you tried
    > compiling CURL against the 10.3.9 SDK?
    >
    > Nick Zitzmann
    > <http://www.chronosnet.com/>
    >
    >
previous month october 2006 next month
MTWTFSS
            1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31          
Go to today